aboutsummaryrefslogtreecommitdiffstats
path: root/cedilla [disowned]
diff options
context:
space:
mode:
Diffstat (limited to 'cedilla [disowned]')
-rw-r--r--cedilla [disowned]/.gitignore1
-rw-r--r--cedilla [disowned]/PKGBUILD32
l---------cedilla [disowned]/upload1
-rwxr-xr-xcedilla [disowned]/watch-20
4 files changed, 54 insertions, 0 deletions
diff --git a/cedilla [disowned]/.gitignore b/cedilla [disowned]/.gitignore
new file mode 100644
index 0000000..7f65160
--- /dev/null
+++ b/cedilla [disowned]/.gitignore
@@ -0,0 +1 @@
+/NEWS.text
diff --git a/cedilla [disowned]/PKGBUILD b/cedilla [disowned]/PKGBUILD
new file mode 100644
index 0000000..4ebfdfe
--- /dev/null
+++ b/cedilla [disowned]/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=cedilla
+pkgver=0.7
+pkgrel=1
+pkgdesc="A simple text printer that uses Unicode internally"
+arch=(any)
+url="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+license=('GPL')
+depends=(clisp texlive-core)
+makedepends=()
+source=(http://www.pps.jussieu.fr/~jch/software/files/$pkgname-$pkgver.tar.gz)
+md5sums=('57d2a80d3fd8fdc72827ada5e6257be2')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./compile-cedilla
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # the install-cedilla script would not find the man path in fakeroot, so
+ # we need to create the dirs for it
+ source cedilla-config
+ mkdir -p $pkgdir/$MANDIR
+
+ TARGET=$pkgdir ./install-cedilla
+ sed -i -e 's/texmf-tetex/texmf-dist/g' $pkgdir/etc/cedilla-config.lisp
+}
+
diff --git a/cedilla [disowned]/upload b/cedilla [disowned]/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/cedilla [disowned]/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file
diff --git a/cedilla [disowned]/watch- b/cedilla [disowned]/watch-
new file mode 100755
index 0000000..c2fa7f1
--- /dev/null
+++ b/cedilla [disowned]/watch-
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+[ -f 'NEWS.text' ] && rm 'NEWS.text'
+wget 'http://www.pps.univ-paris-diderot.fr/~jch/software/cedilla/NEWS.text' >/dev/null 2>/dev/null
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ md5sum < NEWS.text > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'cedilla'
+ fi
+ rm NEWS.text
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'cedilla (unfetchable)'
+fi
+